TS3MusicBot is Discord compatible!
By CrimsonJace
#10553
Hallo,

wir sind seit Donnerstag stolzer Besitzer eines Musikbots auf unserem Teamspeak. Leider mussten wir mehrere Probleme feststellen. So verschwindet der Bot immer mal wieder aus seinem Channel und muss dann über das Webinterface neu gestartet werden. Auch funktioniert das wiedergeben von Youtubelinks nicht ohne dies herunterzuladen. Desweiteren haben wir das Problem das wenn man eine Soundcloudplaylist wiedergeben zu versucht nach jedem Song manuell weiterstellen muss, seitdem der Bot seit heute Nacht seinen Client deaktiviert hat. Diverse Restarts haben diesen ebenfalls nicht wieder eingeschaltet. Wir sind leider mit unserem Latein am Ende und hoffen das uns hier geholfen werden kann.

MfG
CrimsonJace

P.S. für etwaige Fragen zu Details stehen wir Ihnen gerne in diesem Thread zur Verfügung
User avatar
By Crypto90
#10554
Gerne gehen wir all deinen Punkten nach:

So verschwindet der Bot immer mal wieder aus seinem Channel und muss dann über das Webinterface neu gestartet werden.

Welcher Kernel nutzt der Bot-Host Server?
Code: Select alluname -a

In der Konsole eingeben um dies herauszufinden.
Optional lässt sich das auch über das TS3MusicBot Webinterface unter "Aktualisieren" links im Menu sehen. Dort geben wir die Kernel Zeile auch aus.
Wir haben aktuell eine Bug-Meldung dass unter Kernel 4.X die Avatar Funktion spinnt und daher solch ein Channel Switching verursacht werden kann.

Stelle zum Testen einmal das dynamische Avatar in den Einstellungen ab.

Auch funktioniert das wiedergeben von Youtubelinks nicht ohne dies herunterzuladen.

Die direkte Wiedergabe sollte eigentlich funktionieren, diese haben wir seit den neusten Änderungen von Youtube.com mit der neusten TS3MusicBot version wieder zum laufen gebracht.
Youtube Link im Media Browser anklicken oder mittels !yt http://youtubelink Befehl starten, sollte die Wiedergabe direkt starten.
Falls nicht, sehen wir uns das im laufe des Tages gerne an.


Desweiteren haben wir das Problem das wenn man eine Soundcloudplaylist wiedergeben zu versucht nach jedem Song manuell weiterstellen muss, seitdem der Bot seit heute Nacht seinen Client deaktiviert hat.

Das klingt tatsächlich nach einem kleinen Bug, der durch die ganzen Neuerungen und der Youtube Umstellung sich eingeschlichen hat.
Ich werde das einmal durchtesten.

Diverse Restarts haben diesen ebenfalls nicht wieder eingeschaltet. Wir sind leider mit unserem Latein am Ende und hoffen das uns hier geholfen werden kann.


Was genau meinst du mit Client deaktiviert?
Ist das Mikrofon oder der Lautsprecher des Clients deaktiviert?
Falls ja, rufe folgende Adressen auf, passe dabei die IP und Port deines Bot Webinterfaces an:

Code: Select allhttp://webinterfaceip:port/remove1
NICHT DIE 2
http://webinterfaceip:port/remove3
http://webinterfaceip:port/remove4
http://webinterfaceip:port/remove5
http://webinterfaceip:port/remove6
http://webinterfaceip:port/remove7
http://webinterfaceip:port/remove8


Damit löschen wir alle Update Pakete deines Bots, starte ihn anschließend neu. Alle Update Pakete werden dann neu geladen und entpackt. Wir haben somit quasi einen "neu installierten" TS3MusicBot.
By CrimsonJace
#10558
Vielen Dank für die Schnelle Antwort.

hier die Kopie des aktualisierungstabs, da wir leider keine Konsole finden konnten:

Newest version is already installed.
4.6.7.3d (20.01.2018)
Client version: 3.1.6 (remove)
Webinterface version: 4.6.0.2 (remove)
System files version: 4.6.7.7 (remove)
Dependency files version: 4.5.7.9 (remove)
Client libraries version: 3.1.6
java version "1.7.0_79" OpenJDK Runtime Environment (IcedTea 2.5.5) (7u79-2.5.5-0ubuntu0.14.10.2) OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)
Linux hw2sys 3.10.23-xxxx-std-ipv6-64 #1 SMP Tue Mar 18 14:48:24 CET 2014 x86_64 x86_64 x86_64 GNU/Linux


die wiedergabe von youtubelinks über besagten befehl oder gar das webinterface gibt immer folgenden Fehlercode aus:

The given link could not be played.Traceback (most recent call last): File "/usr/lib/python2.7/runpy.py", line 162, in _run_module_as_main "__main__", fname, loader, pkg_name) File "/usr/lib/python2.7/runpy.py", line 72, in _run_code exec code in run_globals File "yt/__main__.py", line 19, in <module> File "yt/youtube_dl/__init__.py", line 465, in main File "yt/youtube_dl/__init__.py", line 455, in _real_main File "yt/youtube_dl/YoutubeDL.py", line 1988, in download File "yt/youtube_dl/YoutubeDL.py", line 784, in extract_info File "yt/youtube_dl/extractor/common.py", line 438, in extract File "yt/youtube_dl/extractor/youtube.py", line 1599, in _real_extract TypeError: argument of type 'NoneType' is not iterable


mit Client deaktiviert meinte ich, dass im Webinterface die Lampe für Client rot war und der bot nicht mehr auf befehle aus dem TS reagierte. Daher rührte meiner Meinung nach auch das Problem mit den Soundcloudplaylists.

Mit freundlichen Grüßen
CrimsonJace
User avatar
By Crypto90
#10561
Code: Select allThe given link could not be played.Traceback (most recent call last): File "/usr/lib/python2.7/runpy.py", line 162, in _run_module_as_main "__main__", fname, loader, pkg_name) File "/usr/lib/python2.7/runpy.py", line 72, in _run_code exec code in run_globals File "yt/__main__.py", line 19, in <module> File "yt/youtube_dl/__init__.py", line 465, in main File "yt/youtube_dl/__init__.py", line 455, in _real_main File "yt/youtube_dl/YoutubeDL.py", line 1988, in download File "yt/youtube_dl/YoutubeDL.py", line 784, in extract_info File "yt/youtube_dl/extractor/common.py", line 438, in extract File "yt/youtube_dl/extractor/youtube.py", line 1599, in _real_extract TypeError: argument of type 'NoneType' is not iterable


Das sollten wir uns einmal ansehen. Sende mir bitte die Webinterface URL dieses Bots zu. Ich sehe mir das an und kümmere mich umgehend darum.
User avatar
By philippe
#10752
Da dieses Thema nicht weiter Beantwortet wird, gehe ich davon aus das es nun Funktioniert und Schließe dieses Thema.
Sollten noch weitere Fragen sein, erstelle bitte ein neuen Thread.

Mit freundlichen Grüßen
Philippe

Wurde gefixt. Bitte auf die Aktuelle Version Upda[…]