Bootstrap Framework 3.3.6

Over a dozen reusable components built to provide iconography, dropdowns, input groups, navigation, alerts, and much more...

If you need help, post your question here.
To relieve the developers a bit, other user can help here too.
User avatar
By Kayway
Posts Avatar
Hi it's me again, I'm running the bot on a 64-bit machine now and it was working well. There was a small issue where if running for long periods of time would stop working but a simple restart would fix the issue.
Except this time :cry: . The bot stopped working, so I stopped it and restarted but now i just get this. I also noticed no logs get generated from the bot so Im guessing its failing before that step.
I have tried the following:
  • Deleted files generated in tmp
  • Re-installed the bot
  • Running as root
My specs:
  • 8GB Ram
  • Debian 12 Buster 64 bit
  • Quad-core CPU
Hopefully this is a simple fix as this bot is amazing :-D .
Last edited by Kayway on Sun Jan 28, 2024 5:35 pm, edited 1 time in total.
User avatar
By Crypto90
Posts Custom Custom Avatar
Downgrade your Java / openjdk jre version, as 17 and higher is not yet supported by our code protection.

We already purchased a new version of our code protection software to support higher/newer Java/openjdk versions very soon.

For now, remove 17 and install an older one like 11 or 9
User avatar
By Crypto90
Posts Custom Custom Avatar
Try setting your teamspeak servers public ip instead your 192…… local lan ip.
The license system is not accepting local lan ips. You should save a public ts ip to your license.
User avatar
By Crypto90
Posts Custom Custom Avatar
If the Java vm fails to start, a log dump will get generated into the system folder (where the TS3MusicBot.jar is located).
You can look if you have some dump files there.

You get absolute no output from the Java process as far as I can see. So I think your Java Vm instance is not starting up correctly, so it should be a general Java issue and not a specific bot issue (I assume).

The license is good, Ip for the license check is also good now.

Java 11 version is also good now.
User avatar
By Crypto90
Posts Custom Custom Avatar
It’s also possible that your Java setup is corrupt. You can try to remove everything Java related (packages) from your system.

you can check installed packages with:
dpkg -l | grep java

And remove it with:
apt-get remove --purge PACKAGENAME

Once everything is removed, install one time clean openjdk-11-jre

This should solve any potential java VM related issues.

Schauen wir uns an.

Der Vollständigkeit halber antworte ich hierz[…]

If nothing from above solves your issue, I can con[…]

Web UI not responding to browser

I tried public IP, LAN IP, and letting it bind to […]

Swap-in out addons, use only what you really need!