Bootstrap Framework 3.3.6

Over a dozen reusable components built to provide iconography, dropdowns, input groups, navigation, alerts, and much more...

If you need help, post your question here.
To relieve the developers a bit, other user can help here too.
User avatar
By Pepreal
Avatar
#11413
Hi, have 2 questions about the musicbot

1. How do i connect the musicbot serverquery via SSH protocol instead of RAW, tried everything but SSH is not working. Is the musicbot supporting SSH query protocol and if not why?

2. Is the musicbot going to support Teamspeak server 5 in the future?

Greetz, Pepreal
User avatar
By Crypto90
Posts Custom Custom Avatar
#11415
Teamspeak 5 connections will be supported once we update the client which is currently in teamspeaks own beta.
We could hop on that, but normally we wait until teamspeak releases its client to stable. But due the long "no updates" time on teamspeaks side, we probably add the current beta client, to be able to get the ts5 server support.


I am already working on adding ssh protocol support for the query connection.
User avatar
By Crypto90
Posts Custom Custom Avatar
#11417
Quick update.

I got everything working with the "teamspeak beta client". The new client will have some more system dependencies, but thats no problem at all.

One point I run into:
Teamspeak does drop 32 bit support completely with their next client.
I will implement a fallback here. If someone still uses a 32 bit system, it falls back to the last 32 bit ts client (which only supports ts3 server connections, no ts5 servers).

Most systems I know which run with a x86 OS are raspberry pi devices, but those since pi3 can also run rasbian with x64 since the cpu is a real 64bit chipset. So a rasbian x64 (arm) OS in addition with box64 installed and running the bots with -notportable (and installing all missing packages the bot shows on start), also works in the futute, also with ts5 connections.

I will look to push the new beta client to our beta and stay it there for a while, since it comes with additional dependencies which hosters have to install.

I also think about adding a check for those new dependencies, if they are installed (its mostly a hosting partner issue), the bot will use the newer clients. If the dependencies are not met, the bot uses the current client and prints some info like "next client update is hold back because of missing dependencies, please install them on the host system to be able to use the newer client", something like that.

This makes sure, if we update the client, that "no bot breaks" if a user clicks on update.

https://t.me/pump_upp - best crypto pumps on teleg[…]

Added functionality to the script to set a path to[…]

Chat Befehle

Falls Discord: Liegt es wahrscheinlich an dem: - […]

dgVoice: PCM Channel closedtime="2023-01-11T[…]

Swap-in out addons, use only what you really need!