Bootstrap Framework 3.3.6

Over a dozen reusable components built to provide iconography, dropdowns, input groups, navigation, alerts, and much more...

By freakyy85
Posts
#7080
Hi I have a question. How can I set up multiple bots? Because the tutorial in the wiki says 2 times the same port number for the webinterface. (just start two instances with same start stop script just with different screen names.) it confuses me and i dont find that logical.also it doesnt tell lme where in what interface i have to set the new nick of the bot etc. it would be nice if someone could explain me step by step how to set up a 2nd musicbot for my licence.

Thanks! :)

freaky.
By Shadow86
#7081
Hi,
How can I set up multiple bots?
If you want to start multiple instances with a private license just change the Port, for example:

screen -S bot1 ./TS3MusicBot_runscript.sh -account EMAIL -port 3000 -webif-pw ADMIN_PASSWORD -webif-pw-user USER_PASSWORD -noquery

screen -S bot2 ./TS3MusicBot_runscript.sh -account EMAIL -port 3001 -webif-pw ADMIN_PASSWORD -webif-pw-user USER_PASSWORD -noquery

screen -S bot3 ./TS3MusicBot_runscript.sh -account EMAIL -port 3002 -webif-pw ADMIN_PASSWORD -webif-pw-user USER_PASSWORD -noquery
where in what interface i have to set the new nick of the bot
After you used the Admin Password for the Webinterface you can change the Nick of the Client under "Settings -> TS3MusicBot Settings"

greetings

Shadow86
By freakyy85
Posts
#7084
hi. did the following:

#!/bin/bash
screen -S ts3bot -m ./TS3MusicBot_runscript.sh -account my@account.tld -port 8090 -webif-pw pw -webif-pw-user pw -noquery
screen -S ts3bot2 -m ./TS3MusicBot_runscript.sh -account my@account.tld -port 8095 -webif-pw pw -webif-pw-user pw -noquery

But the webinterfaces doesnt come up. also both bots say:

TS3MusicBot: Player instance crash detected. Restarted.
TS3MusicBot: TS3 client could not connect after 3 tries. Retry in 60 seconds. [1.] Check if my.ts.ip is online.! [2.] If the ts3 server is password protected save the password in settings. [3.] The security level of the ts3 server has to be 8.
TS3MusicBot: TS3 client could not connect after 3 tries. Retry in 60 seconds. [1.] Check if my.ts.ip is online.! [2.] If the ts3 server is password protected save the password in settings. [3.] The security level of the ts3 server has to be 8.

1 bot is connected though. but i dont know which. and also if i only run 1 bot it works. also the webinterface of the 1st bot is available just not the one of the other bot.
By freakyy85
Posts
#7085
ok right now 1 bot #1 is connected and the 2nd bot sits there and says cant connect to teamspeak server. and also tghe 2nd webinterface doesnt come up i tried several different ports.
By freakyy85
Posts
#7086
now after i started multiple bots if i only start the 1st one the music bot admin group is not set anymore and i cant find it anymore int he settings. i cant scroll down where i can set the music bot admin identity etc.
By Shadow86
#7090
hi,

okay great to hear.

If you want to prevent that your configs get mixed up you can use an additional command -number 1,2,3

for example:

screen -S ts3bot -m ./TS3MusicBot_runscript.sh -account my@account.tld -port 8090 -webif-pw pw -webif-pw-user pw -noquery -number 1
screen -S ts3bot2 -m ./TS3MusicBot_runscript.sh -account my@account.tld -port 8095 -webif-pw pw -webif-pw-user pw -noquery -number 2

greetings

Shadow86
By Shadow86
#7094
Hello,

come on our Support TS3, then we can take a look on it

greetings

Shadow86
TS3MusicBot auf Synology 415+

DANKE!!!!!!!! ich hatte selb error :) danke f&uum[…]

Plex - A Plex media server inspired skin. To i[…]

[THEME] Standard YELLOW

STANDARD YELLOW - Original theme with yellow elem[…]

[THEME] Standard GREEN

STANDARD GREEN - Original theme with green elemen[…]

Swap-in out addons, use only what you really need!